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1 Preface

This document describes the power features of Scripting operation that is available from the license free UDS diagnostic
software- “WT ISO 14229 UDS CAN”".

2 Introduction

This Scripting feature is an extension to the UDS diagnostic tool WT ISO 14229 UDS CAN, it provides a commonly used
programming features in Scripting text; allowing engineers and technicians a handy tool for ECU testing in a repeated
manner, as well as to log the received diagnostic data string in to a file for detail analysis.

It is designed with the following features to enhanced the engineering performance without spending large amount of

money on software tools:

e Scripting commands does not need sophisticated language compiler to operate

e  Scripting commands are stored in files and can be used repeatedly

e UDS commands can be repeated in timely manner, so that the ECU performance can be overserved

e ECU data can be stored in a designated file in a timely and orderly manner for detail analysis by Excel worksheets

e  The communication with the ECU as Device Under Test will be displayed on Screen Dialog display Panel as well as the
log data file, in which they can be copied for Test Report or other documentations.

e On Screen Dialog display for diagnostic communication with ECU can be Copy for documentation.

3 System Requirement and Installation
As mentioned in the Introduction, this Scripting Tool is an extension to “WT I1SO 14229 UDS CAN’ diagnostic toll, therefore
you need to have “WT ISO 14229 UDS CAN” be installed and a Kvaser CAN interface be connected. For more details please
refer to the User Manual of “WT ISO 14229 UDS CAN”.

3.1. Execute the Scripting File

. ‘WT15014229-UDS: RL78 ECU CAN Demo-Generic - x

File 3044 Hardware Setting {412  Offline B  Extra Features EETIME  Help #8h
Device CAN

ic Session
T moonssane | __sxmom

* Standard " Alternate

EcuTxi0 142078 | egien tei fnacorie | isacomr

Service

Service Command: Message Data Preview \ B B 01:26:49
[Supper:Fas 1CM Do by Faneon &= | o e
L,Emc“mm” AllOptions | (E o o [T | ] o

Extra Features E=IN4E  Help #Bh
| RUN Scripting Command Strings ${THIF &S 6%

Show Bootloader Control Panel BRI R

On the tool bar as shown in the above picture, click “Extra Feature” to open the option for “RUN Scripting Command
Strings $ITHIAZRE a5 <, Click this option and follow the instruction to start the Script file operation.

4 Scripting Commands and Formats
4.1. Scripting File Identification

The Scripting file must contain this text string “WT I1SO14229 UDS CAN Tool: Scripting” as a qualify identifier be
recongnised as legitimate Scripting command file.

4.2. Comments

Double back slashes will be recognised as comments, that is any text after “//” will be ignored by the Scripting
processor.
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4.3. Command String format
A standard command string contains a Command and Operand; separated by a “:” as follows:
(Command) : (Operand)

Example 1:
Instruct the Scripting Processor to Pause for 75ms. The Command String will be

Pause : 75
Where “Pause” is a reserved Key word for Pause and 75 = 75 mili-Seconds

Example 2:
To set the Diagnostic session to “Programming, the command string will be:

Tx (DiagnosticMode) : Default
Where
(a) “Tx” =Scripting command for Transmit the command
(b) The Text within the two brackets “(“ “)” is the text description, but in this case the description
“DiagnosticMode” is the reserved key word to set the diagnostic session to “Default”,
Programming”, “Extended”, etc.- See section 9.3.1 for more details.
(c) “Default” is reserved word for Default Session that is 0x01

So, the result of this command execution will be:

Start Diagnostic Session: Default HABAZUIRIE
Req >> 02,10,01
Ack >> 02 50 01

5 Controls for Dialog Display
5.1. Erase the Dialog Display - Erase
Following two commands format are the same to clear the Dialog display:
Format -> Erase: DialogPanel
Or
Erase: MessagePanel
5.2. Show Command String on Dialog Display - Show
This Command to control the message display On or Off on the Dialog display panel
5.2.1. Display All Command String type : CommandStringAll or CmdStrAll

Format -> Show: CommandsStringAll = Status, where Status is On or Off

Example A:

Scripts | show: CommandStringall = On

Output Dialog ...Activated the Display for all command String J&EE RETHEMSFERE

Example B:

Scripts | show: Cmdstrall = off

Output DIaIOg . Deactivated the Display for all command String {&kERATA®SFEAFSE

Note: This OFF command option will also set the CmdStrTx and CmdStrRx as discussed below sections to OFF
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5.2.2. Display Transmit Command String type : CommandStringTx or CmdStrTx
Format -> Show: CommandStringTx = Status, where Status is On or Off

Example A:

Scripts | show: CommandStringTx = On

OUtPUt DIanE ...Activated the Display for all Tx command String &R RFTALEHNGSERS

Example B:

Scripts | show: cmdstrTx = Off

Output Dialog | ... Deactivated the Display for all Tx command String {£iFRRFTA & RS FEGS

5.2.3. Display Receive Command String type : CommandStringRx or CmdStrRx
Format -> Show: CommandStringRx = Status, where Status is On or Off

Example A:

Scripts | show: CommandStringRx = On

Output Dialog | ...activated the Display for all Rx command String GERRETARLIIG S5 S

Example B:

Scripts | show: CmdStrRx = Off

Output Dialog | ... Deactivated the Display for all Rx command String {ZiF B RETEBLIIGLSFES

6 Setting for Transmit Identifiers
6.1. Set Transmit Identifier: SetTxID
WT 1SO14229 UDS CAN Tool supports two transmit ID ie. Alternate for Broadcast ID and Standard for dedicated ECU .
6.1.1. Alternate

Format -> SetTxID: Alternate

Example:

Scripts | setTxID: Alternate

Output Dialog | ««x alternate (Broadcast) Tx CAN ID selected #&f] TIJBECAN-ID: 1ABCD7DFh

6.1.2. Standard

Format -> SetTxID: Standard

Example:

Scripts | setTxID: Standard

Output Dialog | ««x standard Tx CAN 1D selected #EfiT#JFECAN-ID: 1ABCD71Bh
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7 Mathematical Data and Logical Operation

When the 1° character of the command line is a "#”; it signifies that this command line is for

Mathematical;

Logical operation;

Variable assignment;

Constant reference assignment;

ECU Memory Address reference assignment.

This scripting tool provides following memory type references assignment; arithmetic and logical operation:

7.1.

7.2.

7.3.

7.4.

Declaration of an Integer memory Cell - Variable

Use the key word “New Data” to assigned a Data variable to 1 of the 16 Memory Cell, the first 2 characters for the
variable name must be “v_"; i.e.

Format -> #: Variable = <v_Var_Name_1>
or
#: Variable = <v_Var_Name_2, <v_Var_Name_3, .. <v_Var_Name_n>
where n <=16

Example
Scripts | #: Variable = v _Data0
#: Variable = v Datal, v Data2, v Data3
Output Dialog ...Added variable HI¥EHELE: New v_Datal
..Added variable ¥i¥¥{fiZ&’&E: New v Datal, v Data2, v_Data3

Declaration of Constant reference - Constant

Use the key word “New Data” to assigned a Data variable to 1 of the 16 Memory Cell, the first character for the

variable name must be “c_"; i.e.
Format -> #: Constant = <c_Const_Name_n> where 1<=n <=32
Example
SCfiPtS #: Constant = c DIDErase equ OxFF00
#: Constant = c ProDateYYYYMMDD equ 0x20200101
Output Dialog | | added constant FriE A% : New c DIDErase equ OxXFFO00
..Added constant ¥ri¥fIH%(: New c_ProDateYYYYMMDD equ 0x20200101

Declaration of ECU Memory Address reference - ECUAddress

Use the key word “New Data” to assigned a Data variable to 1 of the 16 Memory Cell, the first character for the
variable name must be “a_"; i.e.

Format -> #: ECUAddress = <a_ECU_Address_1> where n <=32

Example

Scripts | #: EcUAddress = a_Speed equ 0x1234FE

Output Dialog | ayged ECU Memory Address HHSHIECUATEMIEE: New a_Speed equ 0x1234FE

Assigning Data value to the Variable

Following data notations are supported for value:

- #:v_Datal0O=0x1234 // assigning a hex value 1234 to variable v_Datal0
- #:v_Data5 =F19%h // Assigning a hex value F199 to variable v_Data5
- #:v_Data4 =300 // Assigning a decimal value of 300 to variable v_Data4
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7.5. Mathematical operators

Following operator supported:

Description Symbol Description Symbol

Addition + A+ B Bit AND & A & B

Subtraction - A - B Bit OR | A | B

Multiplication * A * B Bit Shift Right >> A >> B

Division / A/ B Bit Shift Left << A << B

Bit Exclusive OR ~ A * B Remainder % A %$Bi.e. 14 5 4 =2

Following short form also supported

Description Symbol | Equivalent Description Symbol | Equivalent
A += 3 += A=A+3 A *= 3 += A=A*3
A-=3 += A=2A-3 A /=3 += A=a/3

7.6. Logical Operators

Following logical operator supported:

Description Symbol Description Symbol

Equal = A =B Greater or Equal Than >= A >= B
Greater Than > A > B Less or Equal Than <= A <= B
Less Than < A < B Not Equal != A !=B

7.7. Conditional Statement- If-Then-Else
Format -> Following Condition Statement supported:
#:v_Variablel = If <Condition> Then < Value for True > Else < Value for False >
#:v_Variablel = S(.tondition>? <Value for True> : <Value for False>

Example A: #: v_Data5= if v_Data4=16 then v_Data0

If v_Data 4 value = 16, assign value v_Data0 to v_Data5; otherwise no change to value in Data5

Scripts v_Data5=F19%h
v_Datad=16
v_DatalO=v _Data5*v Data4

: v_Data5 = if v_Data4 = 16 then v_Data0

Sihiiialhia

Output Dialog | ...v Data5 = 61849 (F199h)

..v_Data4 = 16 (10h)
..v_Data0 = 989584 (F1990h)
...v_Datab = 989584 (F1990h)

Example B: #:v_Data5 = (v_Data4 != 16)? V_DataO : v_Data8

If Data 4 value is NOT equal to 16, assign value Data0 to Data5; otherwise assign Data8 value to Data5

Scripts #: Constant = c_DIDErase equ O0xFF00
#: v_Data5 = F19%
#: v_Data4 = 0x100
#: v Data0 = v Data5 * Data4
#: v_Datab = (v_Datad != 0x100)? v_DataO:c_DIDErase
Output Dialog | . . .added constant ¥HEHIEH: New c_DIDErase equ OxFF00
...v_Datab = 61849 (F199h)
...v_Datad = 256 (100h)
...v_Datal = 0 (0h)
...v_Datab = 65280 (FF0Oh)
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Example C: Using If_Then_Else statement for conditional execution

SCﬁptS Pause: 100#: v_Datal = 99

#: v _data0 +=1

Loop: v_datal <= 100

#: v_Data4 = 10
#: v_Data5 = 20
Repeat
#: (void) = (v_Data0=99)? v_Data4+=5 : v_Datab5+=6
//#: (void) = if v Data0!=100 then v Data4+=5 else v Data5+=6

Output Dialog ...v_Data5 = 65280 (FFO00h) ...v_Datal = 99 (63h)
...v_Datad4 = 10 (Ah)
...v_Data5 = 20 (14h)
...Start of Repeat-Loop JIMAEE{E Ll: 1 continue
..v_Data4 15 (Fh)

..v_Data0 = 100 (64h)
...Cont. Repeat-Loop #k4: Ll: 2 Continue
...v_Datab5 = 26 (1Ah)

..v_Data0 = 101 (65h)

..End of Repeat-Loop Zf L1

7.8. Other Keywords for If-Then-Else

Following Keywords are available to enhance the Dialog Display controls, they are

- Newline or BlankLine: To display blank line i.e. add a new line on the dialog panel
- ClearDialog or ClearDialogPanel or EraseDialog or EraseDialogPanel: To erase/clear the Dialog Display panel

Example:
(void) = if v_Data = 10 then ClearDialogPanel else NewLine

Since there is no variable to store the result, thus use “(void)” as instruction for no data saving is required,
when the v_Data = 10, it clear the Display Panel, otherwise just add a blank line to the Dialog Panel.

7.9. Specify Data bit length for data usage

The value assigned to Variables, Constants and Memory Address are stored in 32 bits, following bit length declarators

are available for extractions:

(u8) : use the lowest 8 bits ( 1 byte)
(u16) : Use the lowest 16 bits ( 2 bytes)
(u24) : Use the lowest 24 bits ( 3 bytes)
(u32): Use all 32 bits (4 bytes)

If bit length is not specified, (u8) will be used as default.
Example A:

Script:  #: Constant = c_DIDRdPrgDate equ F199h
#: Constant = c_RdDataByID equ 22h

Tx (Read Programming Date) : c_RdDataByID, (u16)c_DIDRdPrgDate

Result: Tx (Read Programming Date) : 22,F1,99
Example B:

Script: #: Constant = c_RdDataByID equ 0x22
#: Constant = DIDBlankCheck equ OxFEOO
#: ECUAddress = a_ProgStart equ 0x2000
#: Constant = ¢_ProgSize equ OxFFFFF

Tx (ECU Blank Check) : c_RdDataByID, (u16)DIDBlankCheck, (u32) a_ProgStart, (u32)c_ProgSize

Result: Tx (ECU Blank Check) : 22,FE,00,00,00,20,00,00,0F,FF,FF
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8 Scripting Operation Flow Controls
8.1. Pause

This command is to suspend (Pause) the execution for a given time; this is practical usage to allow time for the ECU to
respond.

Format -> Pause: <Time in mili-second>

Example to set the Pause time for 100ms

Scripts | pause: 100

Output Dialog | pause: 100ms

8.2. Repeat - Loop

This “Repeat — Loop” instruction set allows a set of commands be executed orderly in sequential order for number of
specify loops. Nested loop is permissible, but is limited to 10 level of sub loops.

Format ->
Repeat : x [/ where x is the number of Repeat for this main loop Level L1, if x is not specified, continue by default

Command_x_1

Command_x_2

Command_x_3

Repeat : y // Where x is the number of Repeat for this sub loop Level L2
Command_y_1
Command_y_2
Command_y n

Loop: (Condition) // Option to include the condition to repeat; Loop: Continue by default

Command_x_4
Command_x_n

Loop: (Condition) // Option to include the condition to repeat; Loop: Continue by default
8.2.1. Repeat:x

This Repeat instruction sets the start of the command blocks, x is to instruct the script to repeat x number of
command block. If x is omitted; the default will be continuing.

Value x can be a declared variable or constant.
8.2.2. Loop: Condition

This Loop instruction works together with Repeat instruction as discussed above; it serves as the end of the
Command Block.

A Boolean Condition is included as option to exit the Repeat-Loop. If Condition is omitted; the default will be
continuing.

8.2.3. Abort Scripting operation

At start of the running of the scripting file, this button “ABORT Script Operation” |_|
as shown on the right-hand side picture will be pop up on the screen, click this

button to abort the scripting operation as required.
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8.2.4. Repeat-Loop Examples

8.2.4.1. Repeat: 2 - for repeat 2 times with unconditional Loop

Scripts

Repeat: 2
Tx (DiagnosticMode): Default
Pause: 100
Tx (DiagnosticMode): Extended

Pause:100

Loop

Output Dialog

...Start of Repeat-Loop JIAEE{EH Ll: 1 of 2
Start Diagnostic Session: Default #fAZRINIZHIEIE
Req >> 02,10,01

Ack >> 02 50 01

...PAUSE: 100ms

Start Diagnostic Session: Extended #A¥ EBiLHi=iE
Req >> 02,10,03

Ack >> 02 50 03

...PAUSE: 100ms

...Cont. Repeat-Loop #4k&: Ll: 2 of 2

Start Diagnostic Session: Default #fAZRINIZHIEIE
Reqg >> 02,10,01

Ack >> 02 50 01

...PAUSE: 100ms

Start Diagnostic Session: Extended #HA¥ EiZHiEIE
Req >> 02,10,03

Ack >> 02 50 03

...PAUSE: 100ms

...End of Repeat-Loop £5¥ L1

8.2.4.2. Repeat- with conditional Loop for termination

Scripts

#: v_Datal0 = 6 // Preset 6 tp v_Datal0
Repeat
Tx (DiagnosticMode) :
Pause: 100
Tx (DiagnosticMode) :
Pause:100

Default

Extended

#: v Datal0 = v DatalO + 1
loop: v_Datall < 8

Output Dialog

..v_Datald = 6 (6h)
...Start of Repeat-Loop FHAEZE{EIH Ll: 1 continue
Start Diagnostic Session: Default #HABIAZHIEIE
Req >> 02,10,01
Ack >> 02 50 01
...PAUSE: 100ms

Start Diagnostic Session:

Req >> 02,10,03

Ack >> 02 50 03
...PAUSE: 100ms
..v_Datal0 = 7 (7h)
...Cont. Repeat-Loop #k&4:

Start Diagnostic Session:

Req >> 02,10,01
Ack >> 02 50 01
...PAUSE: 100ms

Start Diagnostic Session:

Req >> 02,10,03
Ack >> 02 50 03
...PAUSE: 100ms
...v_Datal0 = 8 (8h)

Extended #A¥ BIZHISTE

Ll: 2 Continue
Default #t ABRINIZHIZTE

Extended #A¥ BIZHISTE

...End of Repeat-Loop ZEH L1
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8.2.4.3. Repeat 10 times, but stop on early with Loop condition

Scripts | 4: v patal0 = 6 // Preset 6 tp v Datal0
Repeat: 10
Tx (DiagnosticMode): Default
Pause: 100
Tx (DiagnosticMode): Extended
Pause:100

#: v_Datal0 = v _Datal0 + 1
loop: v_Datall < 8

Output Dialog | v pataio - 6 (6h)

...Start of Repeat-Loop JIAEE{EH Ll: 1 of 10
Start Diagnostic Session: Default 3 ABRINIZHISIE
Reqg >> 02,10,01

Ack >> 02 50 01

...PAUSE: 100ms

Start Diagnostic Session: Extended #A¥ BiZHiSIE
Req >> 02,10,03

Ack >> 02 50 03

...PAUSE: 100ms

...v_Datal0 = 7 (7h)

...Cont. Repeat-Loop #k&: L1: 2 of 10

Start Diagnostic Session: Default 3 ABRINIZHISIE
Req >> 02,10,01

Ack >> 02 50 01

...PAUSE: 100ms

Start Diagnostic Session: Extended #A¥ BiZHIESIE
Req >> 02,10,03

Ack >> 02 50 03

...PAUSE: 100ms

...v_Datal0 = 8 (8h)

...End of Repeat-Loop %5 L1

8.2.4.4. Nested Repeat 2 times with unconditional loops

Scripts Repeat: 2

Pause: 10

Loop

Uutpatbialos ...Start of Repeat-Loop FHAEEME Ll: 1 of 2

...PAUSE: 10ms

...Cont. Repeat-Loop 4% Ll: 2 of 2
...PAUSE: 10ms

...End of Repeat-Loop ZEH L1
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9 Transmit Diagnostic Command String: Tx
The format for Transmit a diagnostic command CAN message starts with the key word “Tx” as follows:

Format -> Tx (TextDescription) : CAN Message String

\ \— This is the actual user CAN message Data

Text Description is a String to be sent in hexadecimal

commentary note for this ;. 43 11 01 for ECU Reset
Transmit message

9.1. Command Field - Tx (TextDescription)
“Tx" is the script command for transmit a data string and “TextDescription” field has 2 purposes; namely as for name
description of the function command and the other is the Special frequently used Function as described in section 9.3
below.
Example: Following is a sample Command to send out request to read Data voltage
Tx (Read Battery Voltage) :

9.2. Transmit Data String Field “CAN Message String

This data string is in hexadecimal 2 digits format that to be sent, the leading Data Length byte is not required,
the Script routine will automatically add the Data Length byte to complete the format before it is sent.

Example: To send a command string of ReadDataByID (0x22) with DID=0x6203, the script text will be
Tx (Read Battery Voltage) : 22, 62, 03

Following is the Dialog Output

Scripts | 7x (Read Battery Voltage): 22,62,03

Output Dialog | 7x ( Read Battery Voltage ) : 22,62,03
Req >> 03,22,62,03
Ack >> 04 62 62 03 82 bb. .

The last byte of the return string is 0x82 = 12.2V

The Tx string supports declared values for better readability, following is the example

Scripts | #: constant
#: Constant

c_RdDataById equ 0x22
c_DID BattVolt equ 0x6203

Tx (Read Battery Voltage): c_RdDataByID, (ulé6)c_DID BattVolt

Output Dialog | . . .Added constant HiiMfIH#%l: New c RdDataById equ 0x22
...Added constant HI¥IE4: New c_DID BattVolt equ 0x6203

Tx ( read Battery Voltage ) : c_RdDataByID, (ul6)c_DID BattVolt
Req >> 03,22,62,03
Ack >> 04 62 62 03 83 bb.. bb..

For further information on this advance operation in using declared values, please refer to section Error! Reference s
ource not found. for details.
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9.3. Special keywords for “TextDesciption”
In the “TextDescription” field, it supports the following reserved keywords for common usage:
9.3.1. “DiagnosticMode”
Diagnostic mode supports session for Default, Programming, Extended and Supplier as follows:
Format -> Tx (DiagnosticMode) : <Session type>

(a) Default: Tx (DiagnosticMode) : Default will send out 02,10,01

Scripts | 1 (DiagnosticMode) : Default

Output Dialog | start Diagnostic Session: Default HAZKIAZHIAIE
Req >> 02,10,01
Ack >> 02 50 01

(b) Programming: Tx (DiagnosticMode) : Programming will send out 02,10,02

Scripts | Tx (DiagnosticMode) : Programming

Output Dialog | ;.. Diagnostic Session: PROGRAMMING #HAZBBIZUISIE
Req >> 02,10,02
Ack >> 06 50 02 00 19 01 F4

(c) Programming: Tx (DiagnosticMode) : Extended will send out 02,10,02

Scripts | . (DiagnosticMode) : Extended

Output Dialog |start Diagnostic Session: EXTENDED 3 AJ ESHILTE
Req >> 02,10,03
Ack >> 02 50 03

(d) Programming: Tx (DiagnosticMode) : SysSupplier will send out 02,10,02

Scripts Tx (DiagnosticMode) : SysSupplier

Output Dialog |start Diagnostic Session: System Supplier 3t AECU#ENPGE E iZHieis
Req >> 02,10,61
Ack >> 02 50 61

9.3.2. “RequestSeedType”

Command to request Security Seed via the “WT 1S014229 UDS CAN” operating method and auto generate the
send key — See “WT 1S014229 UDS CAN” User Manual for details.

Format -> Tx (RequestSeedType) : <Seed Type>
Following example of the command for request Seed of type 01 and auto send out Security Key in type 02

Tx (RequestSeedType) : 01

Scripts | x (RequestSeedType) : 01

Output Dialog | Request Security Seed iHKRFF :258 01n

Req >>  02,27,01

Ack >> 06 67 01 03 1D 03 1D Gooooo
Request Access Key KIEZE:2A102h

Reqg >> 06,27,02,04,1E, 04, 1E

Ack >> 04 67 02 04 1E Gooo
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10 Processing Received Diagnostic CAN Message: Rx

This Receive CAN Message — Rx command is optional to the Tx command; it is included for verification of the Tx reply
message data string against an expected data string or condition; so that a decision to Continue or Stop the Scripting
operation.

Following are the available options:
10.1. Verify the Reply Message Data : VerifyReplyData

The conditional setting to Continue or Stop upon unmatching of the comparing data strings is described in section
10.3.2

Format -> Rx (VerifyReplyData) : <DD, DD, DD, DD, $5, DS,..... DD>

(U

This is the String to check against the reply
message string, “DD” is the 2 digit Hex data,
“S” serves as the don’t care digit

Example A: Stop Scripting operation upon reply data string is not match

Scripts | #: constant = c_ProDateYYYYMMDD equ 0x20191205
#: Constant = c DIDRdPrgDate equ F19%

ErrorOnReplyData: ReplyDataNotMatch=Stop

Tx (Read Programming Date F199) : 22, (ulé)c_ DIDRdPrgDate
Rx (VerifyReplyData) : 62, (ul6)c_DIDRdPrgDate, (u32)c_ProDateYYYYMMDD
Rx (VerifyReplyData) : 62,F1,99,FF,FF,FF,FF
Tx (DiagnosticMode) : Default
Output | --.Added constant HMIIES: New c_ProDateYYYYMMDD equ 0x20191205

...Added constant Hi¥fNE%: New c DIDRdPrgDate equ F199h

gla og ...Scripting operation will stop on Unmatch Message Response FHIZAHER{ERAEAVCHLH E MR AHE (1
Tx ( Read Programming Date F199 ) : 22, (ul6)c_ DIDRdPrgDate
Req >> 03,22,F1,99
Ack >> 07 62 F1 99 20 19 12 05 155 o
Rx ( VerifyReplyData ) : 07,62,F1,99,20,19,12,05
...Verification &§iif: Reply data string match [EEFRIFEUCH !
Rx ( VerifyReplyData ) : 07,62,F1,99,FF,FF,FF,FF

...Note JEE: Reply data string not match [0/EFRIFEEARUCE !
...Stop Scripting Operation! ifE{ZEIf!

Example B: Continue Scripting operation upon reply data string is not match

Scripts | 4. constant - c_ProDateYYYYMMDD equ 0x20200101
#: Constant = c_DIDRdPrgDate equ F19%h

ErrorOnReplyData: ReplyDataNotMatch= Cont

Tx (Read Programming Date F199) : 22, (ul6)c DIDRdPrgDate
Rx (VerifyReplyData) : 62, (ul6)c DIDRdPrgDate, (u32)c ProDateYYYYMMDD
Tx (DiagnosticMode) : Default

Output | - - .Added constant HHESNIH4L: New c ProDateYYYYMMDD equ 0x20200101

...Added constant HfIH%: New c DIDRdPrgDate equ F199h

Di
) ...Scripting operation will continue on Unmatch Message Response {EARUCECHYHBEMIRNIE » BRI/ R4k S
Tx ( Read Programming Date F199 ) : 22, (ulé6)c DIDRdPrgDate
Req >> 03,22,F1,99
Ack >> 07 62 F1 99 20 19 12 05 15 5
Rx ( VerifyReplyData ) : 07,62,F1,99,20,20,01,01

...Note J¥E: Reply data string not match [HEFRFHEAUCE !
...Continue Scripting Operation! ZkZEFRITHIAIE(E!

Start Diagnostic Session: Default B AZRIAIZHIEIE

Req >> 02,10,01

Ack >> 02 50 01
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10.2. Report on Verify Reply Data: ReportVerifyReplyData

This option is to report on status count on the “Verify Reply Data” from the beginning of Scripted file execution i.e.

Format -> Rx (ReportVerifyReplyData) : Count

Count is a syntax key word must be included

An example of the result display for the “Report Verify Reply Data” of 4 verifications have carried out and were all

match

Scripts

Rx (ReportVerifyReplyData) :Count

Output Dialog

Total Data Verify H# Eoatings ; Matc 8 ; Not Matc :
i 1 ify SEHELIE: 4 h UCHg: 4 h RUCHC: 0

10.3. Declaring Error handling on reply message data

There are two type of declaration are available to stop or continuing the scripting operation, they as follow:

- Negative response; and
- Comparing the reply data string against a specified data string

10.3.1. Negative Response Message: NegativeResponse or NAK

Upon setting a STOP condition for a negative message response, the Scripting Operation will monitor and track
the Reply data string to a transmit message, if it encounters a negative (NAK) response, it will Stop/Abort the

remaining

Format

scripting instructions immediately

ErrorOnReplyData : NegativeResponse = Stop / Continue

Or

ErrorOnReplyData : NAK = Stop / Continue

Note: Short form Cont can be used as Continue

Example A: Stop Scripting operation upon received a NAK (0x7F) reply message

Scripts

ErrorOnReplyData: NAK = Stop

Repeat: 2

Tx (Read ICM Data): BA,02

Rx (VerifyReplyData): FA 02 19 12 16 01 01 02 5A 00 00 FF
Loop

Output
Dialog

...Scripting operation will stop on Negative Message Response FHIZRIE{ENHE TR Y BN HE (-
...Start of Repeat-Loop JFAHEE{EHK Ll: 1 of 2
Tx ( Read ECU Supplier Data ) : BA,02
Reqg >> 02,BA,02
Nak >> 03 7F BA 7F (Service not supported in active session)
. Negative Response received! Abort/Stop operation ! USEIGAHEEIN, iZ{E{ELL !
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Example B: Continue Scripting operation upon received a NAK (0x7F) reply message
SCI‘iptS ErrorOnReplyData: NAK = Cont

Repeat: 2
Tx (Read ECU Supplier Data): BA,02
Rx (VerifyReplyData): FA 02 19 12 16 01 01 02 5A 00 00 FF

Loop
Output |-.-Scripting operation will continue on Negative Message Response T M R Rk SR L T R A IR
Dialog ...Start of Repeat-Loop JIMAEE{EHF Ll: 1 of 2

Tx ( Read ECU Supplier Data ) : BA,02

Reqg >> 02,BA,02

Nak >> 03 7F BA 7F (Service not supported in active session)

...Cont. Repeat-Loop #k4: Ll: 2 of 2

Tx ( Read ECU Supplier Data ) : BA,02

Reqg >> 02,BA,02

Nak >> 03 7F BA 7F (Service not supported in active session)

...End of Repeat-Loop ZE#H L1

10.3.2. Reply Data String Not Match: ReplyDataNotMatch

This setting sets the condition for comparing the Reply data string against a specified data string; whether the
unmatched result should continue or be stopped further scripting command executions.

This section just described the setting for the condition, but the comparison operation is described in section
10.1.

Upon setting a STOP condition for a negative message response, the Scripting Operation will monitor and track
the Reply data string to a transmit message, if it encounters a negative (NAK) response, it will Stop/Abort the
remaining scripting instructions immediately

Format -> ErrorOnReplyData : ReplyDataNotMatch = Stop / Continue

Note: Short form Cont can be used as Continue

Example A: Stop Scripting operation upon reply data string is not matched

Scripts #: Constant = c_ProDateYYYYMMDD equ 0x20191205
#: Constant = c_DIDRdPrgDate equ F19%h

ErrorOnReplyData: ReplyDataNotMatch=Stop

Tx (Read Programming Date F199) : 22, (ul6)c_DIDRdPrgDate

Rx (VerifyReplyData) : 62, (ul6)c_DIDRdPrgDate, (u32)c_ProDateYYYYMMDD
Rx (VerifyReplyData) : 62, (ul6)c_DIDRdPrgDate, FF,FF,FF,FF

Tx (DiagnosticMode) : Default

Output ...Added constant HiEfIE%A: New c ProDateYYYYMMDD equ 0x20191205

...Added constant Hi¥fE%: New c DIDRdPrgDate equ F199h

...Scripting operation will stop on Unmatch Message Response FHIZAER{ERIAEAVCHTH E MR RHE (1
Start Diagnostic Session: Default #FtABRINIZHIETE

Reqg >> 02,10,01

Dialog

Ack >> 02 50 01 P.
Tx ( Read Programming Date F199 ) : 22, (ul6)c_ DIDRdPrgDate
Req >> 03,22,F1,99

Ack >> 07 62 F1 99 20 19 12 05 b..
Rx ( VerifyReplyData ) : 07,62,F1,99,20,19,12,05
...Verification 3&if: Reply data string match [E/&¥RFHEITE !
Rx ( VerifyReplyData ) : 07,62,F1,99,FF,FF,FF,FF

...Note J¥E: Reply data string not match [HEFRIFHEANUCE !
...Stop Scripting Operation! iBfE{Zif!
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Example B: Continue Scripting operation upon replay data string is not match

Scripts

#: Constant = c_ProDateYYYYMMDD equ 0x20191205
#: Constant = c_DIDRdPrgDate equ F19%h

ErrorOnReplyData: ReplyDataNotMatch=Cont

//ErrorOnReplyData: ReplyDataNotMatch= Cont
//ErrorOnReplyData: NegativeResponse = Stop
//ErrorOnReplyData: NegativeResponse = Cont

Tx (DiagnosticMode) : Default

Tx (Read Programming Date F199) : 22, (ul6)c_DIDRdPrgDate

Rx (VerifyReplyData) : 62, (ul6)c_ DIDRdPrgDate,FF,FF,FF,FF

Rx (VerifyReplyData) : 62, (ul6)c_ DIDRdPrgDate, (u32)c_ProDateYYYYMMDD

Output
Dialog

...Added constant HHfIH%l: New c ProDateYYYYMMDD equ 0x20191205

...Added constant HfIH%l: New c DIDRdPrgDate equ F199h

...Scripting operation will continue on Unmatch Message Response FENULHECHYIH BN F » BHAHE(ERFKSE
Start Diagnostic Session: Default #AERINIZHIEIE

Req >> 02,10,01

Ack >> 02 50 01 £
Tx ( Read Programming Date F199 ) : 22, (ul6)c_DIDRdPrgDate
Req >> 03,22,F1,99

Ack >> 07 62 F1 99 20 19 12 05 196 o
Rx ( VerifyReplyData ) : 07,62,F1,99,FF,FF,FF,FF

...Note J¥E: Reply data string not match [HEEORFEAUCE !
...Continue Scripting Operation! ZkEHHITHIAIEIE!

Rx ( VerifyReplyData ) : 07,62,F1,99,20,19,12,05
...Verification Z&iF: Reply data string match [E/E¥RFEICE !

10.4. Display the received Diagnostic Data String: Show

Use this keyword “Show: RxData =" to display the received Diagnostic Data on to the Dialog Display Panel.

Format ->

Where:

Show: RxData = <Function Description> = <Data Interpretation>

- <Function Description> = The name of this function to be displayed
- <Processed of Receive Data> = The result of the received data in Hex/decimal string or in translated value

Following is the list of options available for < Data Interpretation >:
e NS for the translated value to be displayed with value name and unit
e VS for the translated value to be displayed of value only, no name and unit
e DS for displaying the received diagnostic data string in Hexadecimal or Decimal notation
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10.4.1. N$ option for Full Description of Value name and Unit

Format for NS-> Show: RxData = <Function Description> = N$ > <Item_1 name> (Instruction 1) :
<Item_2 name> (Instruction 2).... <ltem_n name> (Instruction n)

Where <Instruction> covers the following Data Type Processing (See section 11 For more details)-
- Formula Calculation

- Value description translation

- Bit position interpretation

- ASCll interpretation

- BCD or HEX notation display

Example A: NS for Formula calculation

Scripts | Tx (k130): c_RdDataByID, (ul6)c_ DID RAVbattIEEE
Show: RxData = KL30-Full Desc = N$ > IEEE Batt.Volt (F;1;4;IEEE754;V) :Norm
Batt.Volt (F;5;1;D*0.1;V)

Output Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE
. Req >> 03,22,64,03
Dialog |acx >> 08 62 64 03 41 51 99 9a 83 bd.AQ. ..
...KL30 - Full Desc: IEEE Batt.Volt = 13.1000003814697 V, Norm Batt.Volt = 13.1 V

Example B: NS For Value interpretation

Scripts Show: RxData = TCU = N$ > Gear Position(V;1;1;{0=Invalid|l=1st Gear|2=2nd Gear|3=3rd
Gear|4=4th Gear|5=5th Gear| 6=6th Gear| 7=7th Gear| 8=8th Gear| 9=9th
Gear|10=Low|1ll=Drive|l2=Netural|l3=Reverse|l4=Park| 15=Invalid/Limp}), Word

Output Tx ( TCU ) : 22, (ul6)a DID GearSts
. Req >>  03,22,62,07
Dialog |ack >> 04 62 62 07 06 bb. ..

...TCU: Gear Position = 6th Gear

Example C: NS For Bit Position interpretation

Scripts Show: RxData = ICM = N$ > Trafficator Status(B;1l;1;{0=Trafficator Right | 1l=Trafficator Left |
2=Vehicle Move}), Word

Output |Tx ( ICM ) : 22,62,08
. Req >>  03,22,62,08
Dialog |ack >> 04 62 62 08 00 ob. .

...ICM: Trafficator Status = bit 0: Trafficator Right = 0; bit 1: Trafficator Left = 0; bit 2:
Vehicle Move = 0

Example D: NS for Ascii interpretation

Scripts Tx (SW Version): 22,F1,88
Show: RxData = ECU Sw Version = N$ > Sw Version (Ascii)

Output |Tx ( SW Version ) : 22,FL,88
Req >> 03, 22,Fl, 88

Dialo,
J Ack >> 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E  b..V2020. 07. 18.
30 31
...ECU Sw Version: Sw Version = V2020.07. 18. 01 01

Example E: NS for Hex or BCD display

Scripts Tx (SW Version): 22,F1,88
Show: RxData = ECU Sw Version = N$ > Sw Version (BCD)

Output |Tx ( SW Version ) : 22,FL,88

Req >> 03, 22,F1, 88

Ack >> 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E  b..V2020.07. 18.
30 31

...ECU Sw Version: Sw Version = 56-32-30-32-30-2E-30-37-2E-31-38-2E-30-31

Dialog
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10.4.2. V$ option for Value only
Note: VS format is almost the same as NS, but for VS, the output display will not show the Item Name and Unit

Format for VS-> Show: RxData = <Function Description> = V$ > <Item_1 name> (Instruction 1) :
<ltem_2 name> (Instruction 2).... <ltem_n name> (Instruction n)

Where <Instruction> covers the following Data Type Processing (See section 11 For more details)-
- Formula Calculation

- Value description translation

- Bit position interpretation

- ASCll interpretation

- BCD or HEX notation display

Example A: VS for Formula calculation

Scripts | rx (k130): ¢ RdDataByID, (ul6)c DID RdVbattIEEE
Show: RxData = KL30-Value Only = V§ > IEEE Batt.Volt(F;1l;4;IEEE754;V) :Norm
Batt.Volt (F;5;1;D*0.1;V)

Output Tx ( KL30 ) : c_RdDataByID, (ulé)c_DID RdVbattIEEE
. Req >>  03,22,64,03
Dialog |ack >> 08 62 64 03 41 51 99 9A 83 bd.2Q. ..

...KL30 - Value Only: 13.1000003814697, 13.1

Example B: VS For Value interpretation

Scripts | Show: RxData = TCU = V$ > Gear Position(V;1;1;{0=Invalid|l=1st Gear|2=2nd Gear|3=3rd
Gear|4=4th Gear|5=5th Gear| 6=6th Gear| 7=7th Gear| 8=8th Gear| 9=9th
Gear|10=Low|1ll=Drive|1l2=Netural|l3=Reverse|l4=Park| 15=Invalid/Limp}), Word

output Tx ( TCU ) : 22, (ul6)a_DID_GearSts
. Req >> 03,22,62,07
Dialog |ack >> 04 62 62 07 06 e

...TCU: 6th Gear

Example C: VS For Bit Position interpretation

Scripts Show: RxData = ICM = V§ > Trafficator Status(B;1;1;{0=Trafficator Right | 1=Trafficator Left |
2=Vehicle Move}), Word

output Tx ( ICM ) : 22,62,08
. Req >> 03,22,62,08
Dialog |ack >> 04 62 62 08 02 b. .

...Gear: bit 0: Trafficator Right = 0; bit 1: Trafficator Left = 1; bit 2: Vehicle Move = 0

Example D: VS for Ascii interpretation

Scripts |Tx (SW Version): 22,F1,88
Show: RxData = ECU Sw Version = V$ > Sw Version(Ascii)

Output |Tx ( SW Version ) : 22,FL,88
Req >> 03, 22,F1, 88

Dialo
J Ack >> 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E  b..V2020. 07. 18.
30 31
...ECU Sw Version: V2020.07.18. 01 01

Example E: VS for Hex or BCD display

SCfiptS Tx (SW Version): 22,F1,88
Show: RxData = ECU Sw Version = V$ > Sw Version (BCD)

Output |Tx ( SW Version ) : 22,Fl, 88

Dialog Req >>  03,22,F1,88

Ack >> 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E  b..V2020.07. 18.
30 31

...ECU Sw Version: 56-32-30-32-30-2E-30-37-2E-31-38-2E-30-31
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10.4.3. D$ Option for the complete received diagnostic Data string

This $SD option is slightly different to the Hex or BCD option in NS and VS, the entire received diagnostic Data
string will be displayed and separated by Comma or Tab space, primary for File output that can be ported to
Excel for analysis.

Format (DS ) for Hexadecimal -> Show: RxData = <Function Description>=D$ = (Hex)
Format (DS) for Decimal -> Show: RxData = <Function Description>=D$ = (Dec)

Example A: for the display the received Data String in Hexadecimal notation

Tx (SW Version): 22,F1,88
Show: RxData = ECU Sw Version = D$ > (Hex)

Scripts

Output |Tx ( SW Version ) : 22,F1, 88
Req >>  03,22,F1,88
Ack >> 11 62 F1 88 56 32 30 32 30 2B 30 37 2E 31 38 2E  b..V2020.07. I8.
30 31
...BCU Sw Version: (Hex) 11,62, F1,88, 56, 32, 30, 32, 30, 2E, 30, 37, 2E, 31, 38, 2E, 30, 31

Dialog

Example B: for the display the received Data string in decimal notation

Scripts Tx (SW Version): 22,F1,88
Show: RxData = ECU Sw Version = D$ > (Dec)

Output Tx ( SW Version ) : 22,F1, 88
Req >> 03, 22, F1, 88
Ack >> 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E  b..V2020. 07. 18.
30 31
...ECU Sw Version: (Dec) 17,98, 241, 136, 86, 50, 48, 50, 48, 46, 48, 55, 46, 49, 56, 46, 48, 49

Dialog

11 Data Interpretation: Formula-Value-Bit-Ascii-Hex-BCD
There are 3 types of translation are available as follows:
11.1. Formula (F)
Format -> (F,<Start Position>, <Data Length>,<Formula>,<Unit>)

Where:
- <Start Position> : The position of the actual Received Diagnostic Data bytes, that is after the UDS commands and

parameters
- <Data Length>: Number of bytes for the Data
- <Formula>: Mathematical formula or IEEE-754 Floating Point Calculation
- <Unit>: To be Displayed after the result
The received diagnostic data can be translated by the following parameters:

Example A: (F;1;4;IEEE754;V) for Voltage

-> “F” = Formula type, 1% Data Position of 4 byte long with Unit “V”; the calculation will be in IEEE-754
Floating Point

Received Data : 08 62 64 03 41 51 99 9A 83 Note: The yellow highlighted part is the actual Data
Result -> 0x413E6666 = IEEE754( 0x413E6666 ) = 13.1000003814697 V

Example B: (F;5;1;D0*0.1;V) for Voltage
-> “F” = Formula type, 5" Data Position of 1 byte long with Unit “V”; the calculation will be Data x 0.1
Received Data : 08 62 64 03 41 51 99 9A 83 Note: The yellow highlighted part is the actual Data

Result ->0x83=131x0.1=13.1V
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11.2. Value (V)

Format -> (V,<Start Position>, <Data Length>,<Value Description>)

Where:

- <Start Position> : The position of the actual Received Diagnostic Data bytes, that is after the UDS commands and
parameters

- <Data Length>: Number of bytes for the Data
- <Value Description>: Reference Description of all value combinations

Example: (V;1;1;{0=Invalid | 1=1st Gear|2=2nd Gear|3=3rd Gear|4=4th Gear|5=5th Gear| 6=6th Gear| 7=7th Gear|
8=8th Gear| 9=9th Gear|10=Low|11=Drive|12=Netural|13=Reverse|14=Park| 15=Invalid/Limp})

-> “V” = Value type, 1%t Data Position of 1 byte long, Index Reference for Gear Position
Received Data : 05 62 62 07 0402 Note: The yellow highlighted part is the actual Data
Result -> 0x04 = 4th Gear
11.3. Value (B)
Format -> (V,<Start Position>, <Data Length>,<Value Description>)
Example: (B;2;1;{0=Trafficator Right | 1=Trafficator Left | 2=Vehicle Move})
-> “B” = Bit type, 1% Data Position of 1 byte long, Bit index interpretation
Received Data : 0562 62 07 04 02 Note: The yellow highlighted part is the actual Data
Result -> 0x02= bit 0: Trafficator Right = 0; bit 1: Trafficator Left = 1; bit 2: Vehicle Move =0
11.4. Ascii Notation

Format -> (Ascii)

Note: Data position and length is not required as it will interpret the entire data section of the received
diagnostic data string

Example:

Received Data : 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E 30 31
Result ->Vv2020.07.18.01

11.5. Hex or BCD Notation

Format -> (Hex)
Format -> (BCD)

Note:
a) Hexand BCD produced the same output

b) Data position and length is not required as it will interpret the entire data section of the
received diagnostic data string
Example:
Received Data : 11 62 F1 88 56 32 30 32 30 2E 30 37 2E 31 38 2E 30 31
Result -> 56-32-30-32-30-2E-30-37-2E-31-38-2E-30-31
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12 Save Rx data to Log File
Following are available commands for File operations:
e  File: OpenlLogrFile = <Set Data Separator Type >
e  File: DataSeparator = <Comma/Tab >
e  File: Print = <Text to be printed to file>
e  File: RxData = <Instruction>
12.1. Open/Create a log file
Prior to saving the received diagnostic Data into a file, the file needs to be created.
Use this command File: OpenLogFile = <Set Data Separator Type > to create a log file and set the data separator for the
output data string. A Save File Dialog Window will pop up, follows the on screen instruction to set up the log file. While
the <Set Data Separator Type > will be processed to set the data separator for the output data i.e. Comma or TAB
space.
12.1.1. Set Comma as Data Separator
Format -> File: OpenLogFile = Use Comma For Data Separator
Or
Format -> File: OpenlLogFile = UseCommaForDataSeparator
Or
Format -> File: OpenLogFile = DataSeparator = Comma
12.1.2. Set Tab Space as Data Separator
Format -> File: OpenLogFile = Use Tab For Data Separator
Or
Format -> File: OpenLogFile = UseTabForDataSeparator
Or
Format -> File: OpenlLogFile = DataSeparator = Tab
The advantage of using TAB spacing as the Data separator is the data can be Copied and Paste directly on to the Excel
Worksheet’s working cells.
Example of using comma as data separation
07,62,F1,00,01,02,03,04
Tab Space

Example of using Tab Space for data separation

07 62 F1 00 01 02 03 04
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12.2. Set Data Separator
This option is to allow the output data separator be changed any time during the running of the Scripting commands.
Format -> File: DataSeparator = <Comma/Tab >
Example for using Comma as Data separator:
File: DataSeparator = Comma
Example for using Tab Space as Data separator:
File: DataSeparator = Tab
12.3. Print a text line on to the log file
This option is provided for output a text note on to the log file
File: Print = <Text to be printed to file>
Example:
File: Print = Start of Vehicle Testing
Text string “Start of Vehicle Testing” will be output to the log file
12.4. Output the received diagnostic data to log file
Use this keyword “File: RxData =" to display the received Diagnostic Data on to the Log File.

Note: This file command structure is identical to “Show: RxData =" as described in section 10.4, the interpreted data
will be output to the Log File, instead of showing it on the Dialog Display.

Format -> Show: RxData = <Function Description> = <Data Interpretation>
Where:
- <Function Description> = The name of this function to be displayed
- <Processed of Receive Data> = The result of the received data in Hex/decimal string or in translated value
Following is the list of options available for < Data Interpretation >:
e NS for the translated value to be displayed with value name and unit
e VS for the translated value to be displayed of value only, no name and unit
e DS for displaying the received diagnostic data string in Hexadecimal or Decimal notation

Please also refer to section 10.4 and section 12 for full details discussion on <Data Interpretation> and samples.

Example A: NS Log Data for Formula calculation

Scripts | Tx (XL30): c_RdDataByID, (ul6)c DID RdVbattIEEE
File: RxData = KL30-Full Desc = N$ > IEEE Batt.Volt(F;1;4;IEEE754;V):Norm Batt.Volt(F;5;1;D*0.1;V)

Output |7x ( KL30 ) : c RdDataByID, (ul6)c DID RdVbattIEEE
Dialog |Rea >>  03,22,64,03
Ack >> 08 62 64 03 41 51 99 9A 83 bd.AQ. ..
Output
Fil 23:07:08.085, KL30 - Full Desc, IEEE Batt.Volt = 13.1000003814697 V, Norm Batt.Volt = 13.1 V
ile
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Example B: VS Log Data for Formula calculation

Scripts | 1y (k530): c_RdDataByID, (ul6)c DID RdVbattIEEE
File: RxData = KL30-Value Only = V$ > IEEE Batt.Volt(F;1;4;IEEE754;V):Norm Batt.Volt(F;5;1;D*0.1;V)

Output |7x ( KL30 ) : c RdDataByID, (ul6)c DID RdVbattIEEE
Dialog |Rea >>  03,22,64,03

Ack >> 08 62 64 03 41 51 99 9A 83 bd.2Q. ..
Output

File |23:07:08.145, KL30-Value Only, 13.1000003814697, 13.1

Example C: NS Log Data for Value and Bit Interpretation

Scripts | Tx (TCU): 22, (ul6)a DID GearSts

File: RxData = TCU = N$ > Gear Position(V;1;1;{0=Invalid|l=1st Gear|2=2nd Gear|3=3rd Gear|4=4th

Gear |5=5th Gear| 6=6th Gear| 7=7th Gear| 8=8th Gear| 9=9th Gear|10=Low|ll=Drive|l2=Netural
13=Reverse| l4=Park| 15=Invalid/Limp}):Trafficator Status(B;2;1;{0=Trafficator Right | l=Trafficator
Left | 2=Vehicle Move}),Word

Output
. Tx ( TCU ) : 22, (ul6)a DID GearSts
Dialog |req >> 03,22,62,07
Ack >> 05 62 62 07 03 02 15196 o o
Output 07 ition = 3% - - bit 0: ; et = @ B
23:07:08.285, TCU, Gear Position = 3*¢ Gear, Trafficator Status = bit 0: Trafficator Right = 0; bit

File |1: Trafficator Left = 1; bit 2: Vehicle Move = 0

Example D: VS Log Data for Value and Bit Interpretation

Scripts | Tx (Tcu): 22, (ul6)a DID GearSts

File: RxData = TCU = V$ > Gear Position(V;1;1;{0=Invalid|l=1st Gear|2=2nd Gear|3=3rd Gear|4=4th
Gear|5=5th Gear| 6=6th Gear| 7=7th Gear| 8=8th Gear| 9=9th Gear|10=Low|ll=Drive|l2=Netural|
13=Reverse| 14=Park| 15=Invalid/Limp}):Trafficator Status(B;2;1;{0=Trafficator Right | 1=Trafficator
Left | 2=Vehicle Move}),Word

Output
. Tx ( TCU ) : 22, (ulé)a_DID_GearSts
Dialog |zeq >>  03,22,62,07
Ack >> 05 62 62 07 03 02 bb...
OUtpUt 23:07:08.285, 3% Gear, bit 0: Trafficator Right = 0; bit 1: Trafficator Left = 1; bit 2: Vehicle

File [Move = 0

Example E: DS Log Data for Hexadecimal notation

Scripts [ rx (Tcu): 22, (ul6)a DID GearSts
File: RxData = TCU = D$ > (Hex)

Output
. Tx ( TCU ) : 22, (ul6)a DID GearSts
Dialog |req >>  03,22,62,07
Ack >> 05 62 62 07 03 02 bb. ..
Output

File 01:06:55.734, TCU, (Hex),05,62,62,07,03,02

Example F: DS Log Data for Decimal notation

Scripts | Tx (TCU): 22, (ul6)a DID GearSts
File: RxData = TCU = D$ > (Dec)

Output
. Tx ( TCU ) : 22, (ul6)a DID GearSts
Dialog |req >> 03,22,62,07
Ack >> 05 62 62 07 03 02 bb. ..
Output

File 01:06:55.739, TCU, (Dec),5,98,98,7,3,2
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13 Appendix A: Multi-Loop Scripting file sample

This exercise demonstrates the reading of the Battery Voltage (KL30) from ECU via ReadDataByID command, it illustrates
the use of Multi-Loop and timing control to retrieve the data.

The demonstration covers:

e Use of Variable and Constant values

e  Multi-Loop operational controls

e  Output information on to the Panel Display as well as to a file

e  Processed data in form of just Hex string, Full Description and Value Only

13.1. Original Scripting Text in File

*** WT I1S014229 UDS CAN Tool: Scripting *** // This is the Scripting File Identification
Erase: DialogPanel

//ErrorOnReplyData: ReplyDataNotMatch=Stop
ErrorOnReplyData: ReplyDataNotMatch= Cont

//ErrorOnReplyData: NegativeResponse = Stop
//ErrorOnReplyData: NegativeResponse = Cont

Show: CmdStrAll = On
#: Variable = v Data0
#: Variable = v_Datal, v_Data2, v_Data3 // Declaring 3 variables
Show: CmdStrAll = Off
#: Variable = v_Data4

Variable = v_LoopCounter

Constant = c_RdDataByID equ 0x22
Constant = c_DID RdVbattIEEE equ 0x6403
Constant = c_50ms equ 50

Constant = c_10ms equ 100

H= = H S

Show: CmdStrAll = Off

File: OpenLogFile = Use Comma for Data Separator // or Tab
//File: DataSeparator = Comma // or Tab

File: Print = // Blank Line
File: Print =
LR RS RS RS S S S S S SRS RS RS S SRS RS RS S ESE SRS ESESESESESESESESESESESESESESESESEEESEEESEEEEEREEEEEEEEEEEEEEESEEEEEEEEE S

File: Print = *** Note: Comma is used for Data separator for this exercise
File: Print =
LR RS RS RS S S S SRS S SRS RS S SRS RS RS SRS ESESESESE S S S SES S S S S ESSEESESEEEEEEESESESESEEEEEEEEEEEEEEEEEEEEEEEEE S

File: Print = // Blank Line
#: v_LoopCounter = 2

Repeat
Tx (DiagnosticMode): Default

File: Print = *** Just the received Diagnostic Data String
Repeat: 3
Tx (KL30): c_RdDataByID, (ul6)c_DID_RdVbattIEEE
Show: RxData = KL30 = DS$ > (Hex)
File: RxData = KL30 = D$ > (Hex)
Pause: c_50ms
Loop

File: Print = *** Battery Value only

Repeat: 3
Tx (KL30): c_RdDataByID, (ul6)c DID RdVbattIEEE
Show: RxData = KL30 = V$> IEEE Batt.Volt (F;1;4;IEEE754;V) :Norm Batt.Volt (F;5;1;D*0.1;V)
File: RxData = KL30 = V$> IEEE Batt.Volt(F;1;4;IEEE754;V) :Norm Batt.Volt(F;5;1;D*0.1;V)
Pause: c_50ms

Loop

File: Print = *** Battery Value in Full Description

Repeat: 3
Tx (KL30): c_RdDataByID, (ul6)c DID RdVbattIEEE
Show: RxData = KL30 = N$> IEEE Batt.Volt(F;1;4;IEEE754;V):Norm Batt.Volt (F;5;1;D*0.1;V)
File: RxData = KL30 = N$> IEEE Batt.Volt(F;1;4;IEEE754;V) :Norm Batt.Volt(F;5;1;D*0.1;V)
Pause: c_50ms

Loop

Pause:c_10ms
#: v_LoopCounter = v_LoopCounter -1

loop: v_LoopCounter != 0
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13.2. Output on Dialog Display Panel

=== Start of Scripting Commands in File FHAHITHIARE ===

...Scripting operation will continue on Unmatch Message Response fEA

VCECHOE SRS - RAERIE R 4R LR

...Activated the Display for all command String AUEERFIAMITFEHS
Cmd @M% >> # : Variable = v Data0

...Added variable HIEEIELE: New v_Datal

Cmd @% >> # : Variable = v_Datal, v_Data2, v_Data3

...Added variable MIBHIELTE: New v_Datal, v_Data2, v_Data3

Cmd #% >> Show : CmdStrAll = Off

...Deactivated the Display for all command String BILERFIBMLERS

.Added variable FZEIELE: New v_Data4

.Added variable HIBEIBELE: New v_LoopCounter

.Added constant HIEMEX: New c RdDataByID equ 0x22

.Added constant HIEMEX: New c DID RdVbattIEEE equ 0x6403
.Added constant FIGIEHE: New c_50ms equ 50

.Added constant FIEMEE: New c_10ms equ 100

.Deactivated the Display for all command String BIEERFIAMITERTS

...File: E:\VB.NET\WT-UDS CAN 2020\Validation\Scripting Log
Data\Testl.log

...Comma symbol will be used to separate data output @SHSHATHR

HiRmE

..Ready to Save Diagnostic Data ERRTFHIALIE

.v_LoopCounter = 2 (2h)

.Start of Repeat-Loop FHAEEMEH L1: 1 continue
Start Diagnostic Session: Default HAZHAZHIAIE
Req >> 02,10,01

Ack >> 02 50 01 P.
...Start of Repeat-Loop FYAEEMEI 12: 1 of 3
Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE

Req >> 03,22,64,03

Ack >> 08 62 64 03 41 50 00 00 82 bd.AP...

...KL30: (Hex) 08,62,64,03,41,50,00,00,82
...PAUSE: 50ms

...Cont. Repeat-Loop #£X 12: 2 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE
Req >> 03,22,64,03

Ack >> 08 62 64 03 41 4E 66 66 81 bd.ANff.

...KL30: (Hex) 08,62,64,03,41,4E,66,66,81
...PAUSE: 50ms

...Cont. Repeat-Loop #£L 12: 3 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Req >> 03,22,64,03

Ack >> 08 62 64 03 41 4C CC CD 80 bd.AL...

...KL30: (Hex) 08,62,64,03,41,4C,CC,CD, 80
...PAUSE: 50ms

...End of Repeat-Loop %3 L2 and Resume Repeat-Loop £l L1
...Start of Repeat-Loop FYAEEMEI 12: 1 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE
Req >> 03,22,64,03

Ack >> 08 62 64 03 41 4C CC CD 80 bd.AL...

...KL30: 12.8000001907349, 12.8

...PAUSE: 50ms

...Cont. Repeat-Loop #£L 12: 2 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Req >> 03,22,64,03

Ack >> 08 62 64 03 41 4E 66 66 81 bd.ANff.

...KL30: 12.8999996185303, 12.9

...PAUSE: 50ms

...Cont. Repeat-Loop #£L 12: 3 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Req >> 03,22,64,03

Ack >> 08 62 64 03 41 51 99 9A 83 bd.RQ. ..

...KL30: 13.1000003814697, 13.1
...PAUSE: 50ms

...End of Repeat-Loop %% 12 and Resume Repeat-Loop £ L1

...Start of Repeat-Loop HYAEEMEI 12: 1 of 3
Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Req >>  03,22,64,03

Ack >> 08 62 64 03 41 50 00 00 82 bd.AP. ..

...KL30: IEEE Batt.Volt = 13 V, Norm Batt.Volt = 13 V
...PAUSE: 50ms
...Cont. Repeat-Loop ##L 12: 2 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE
Reqg >> 03,22,64,03

Ack >> 08 62 64 03 41 50 00 00 82 bd.AP...
...KL30: IEEE Batt.Volt = 13 V, Norm Batt.Volt = 13 V
...PAUSE: 50ms

...Cont. Repeat-Loop %L L2: 3 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE

Req >> 03,22,64,03

Ack >> 08 62 64 03 41 51 99 9A 83 bd.AQ. ..
...KL30: IEEE Batt.Volt = 13.1000003814697 V, Norm Batt.Volt = 13.1
v

.PAUSE: 50ms
.End of Repeat-Loop #® L2 and Resume Repeat-Loop IF%L L1
..PAUSE: 100ms
.v_LoopCounter = 1 (1h)
.Cont. Repeat-Loop #%E L1: 2 Continue
Start Diagnostic Session: Default HABAZHMIRIE
Req >> 02,10,01

Ack >> 02 50 01 P.
...Start of Repeat-Loop FYAEEMEIF 12: 1 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE

Req >> 03,22,64,03

Ack >> 08 62 64 03 41 51 99 9A 83 bd.RQ. ..

...KL30: (Hex) 08,62,64,03,41,51,99,9A,83
...PAUSE: 50ms

...Cont. Repeat-Loop 4%k 1L2: 2 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Reqg >> 03,22,64,03
Ack >> 08 62 64 03 41 51 99 9A 83 bd.RAQ. ..

...KL30: (Hex) 08,62,64,03,41,51,99,9A,83
...PAUSE: 50ms

...Cont. Repeat-Loop %k 1L2: 3 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Req >> 03,22,64,03
Ack >> 08 62 64 03 41 51 99 9A 83 bd.AQ...

...KL30: (Hex) 08,62,64,03,41,51,99,93,83
...PAUSE: 50ms

...End of Repeat-Loop %3 L2 and Resume Repeat-Loop £ L1
...Start of Repeat-Loop FMAEEMEN 12: 1 of 3

Tx ( KL30 ) : c_RdDataByID, (ulé6)c_DID RdVbattIEEE
Reqg >> 03,22,64,03
Ack >> 08 62 64 03 41 51 99 9A 83 bd.RAQ...

...KL30: 13.1000003814697, 13.1
...PAUSE: 50ms

...Cont. Repeat-Loop 4%k 1L2: 2 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE
Req >> 03,22,64,03
Ack >> 08 62 64 03 41 51 99 9A 83 bd.AQ...

...KL30: 13.1000003814697, 13.1
...PAUSE: 50ms

...Cont. Repeat-Loop %X 1.2: 3 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE
Req >> 03,22,64,03
Ack >> 08 62 64 03 41 53 33 33 84 bd.AS33.

...KL30: 13.1999998092651, 13.2
...PAUSE: 50ms

...End of Repeat-Loop %3 L2 and Resume Repeat-Loop &L L1
...Start of Repeat-Loop FAEEMEI 12: 1 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE

Req >> 03,22,64,03

Ack >> 08 62 64 03 41 51 99 9A 83 bd.AQ...
...KL30: IEEE Batt.Volt = 13.1000003814697 V, Norm Batt.Volt = 13.1
v

...PAUSE: 50ms
...Cont. Repeat-Loop %L 1.2: 2 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE

Req >> 03,22,64,03

Ack >> 08 62 64 03 41 50 00 00 82 bd.AP...
...KL30: IEEE Batt.Volt = 13 V, Norm Batt.Volt = 13 V

...PAUSE: 50ms
...Cont. Repeat-Loop %X 1.2: 3 of 3

Tx ( KL30 ) : c_RdDataByID, (ul6)c_DID RdVbattIEEE

Req >> 03,22,64,03

Ack >> 08 62 64 03 41 4E 66 66 81 bd.ANff.
...KL30: IEEE Batt.Volt = 12.8999996185303 V, Norm Batt.Volt = 12.9
v

.PAUSE: 50ms

.End of Repeat-Loop %3 L2 and Resume Repeat-Loop #H4¢ L1
..PAUSE: 100ms
.v_LoopCounter = 0 (Oh)

.End of Repeat-Loop R L1

=== End of Scripting Commands in File #ZRHITHARE ===

UM WT 1S014229 UDS CAN Scripting V1.00.docx

Page 27 of 30



WT ISO 14229 UDS CAN-Scripting

13.3. Output of Log File

[ ] kK ok ok K ok ok ok ok K ok ok ok ok ok K ok ok ok ok K ok ok K ok ok K ok ok o ok K ok ok K ok ok K ok ok o ok K ok ok K ok ok K ok ok o ok K ok ok ok ok ok K ok ok K ok ok ok ok K ok ok K ok k Kk K

//
//
//
//
//
//
//
//
//
//
//
//
//

WT UDS CAN Scripting - Log File for Diagnostic Receive Data

Init File selected: UDS Demo ECU CAN-Generic 29bit ID w_IEEE754 200717.ini
Scripting File Directory: M:\A3\Diagnostic\MI1A Brazil\EEPROM update
Scripting File name: AppendixA-RdDataByID - Battery Voltage .scp

Tester Transmit ID - Std: 0x1ABCD71B
- Alt: 0x1ABCD7DF
Tester Receive ID: 0x1ABCD79B

Date: 2020-Jul-29
Time: 16:04:35.697

[ kK ok ok K ok ok ok ok K ok ok ok ok ok K ok ok ok ok K ok ok K ok ok K ok ok o ok K ok ok K ok ok K ok ok K ok K ok ok K ok ok K ok ok ok ok K ok ok K ok ok K ok ok K ok K ok ok K ok ok K ok ok K kK

hkkk ok kkkkk ok kkk ok k ok kkkkkkk ok kkkhkkk ok kkkkkhk ok k ok k ok k ok kkkkk ok k ok k ok kkkkkkkkkkk ok k ok kkkkkkkkkkkkkhkkkkkkkkkkkkkkkkkkkkk ok k%

*** Note: Comma is used for Data separator for this exercise
LR R SRR EEE R RS R R R R R R R R R R R SRR ERE RS EEREREEEEEEEEEEEEEEEEEESESE]

*** Just the received Diagnostic Data String

16
16
16

:04:38.656, KL30, (Hex),08,62,64,03,41,50,00,00,82
:04:38.845, KL30, (Hex),08,62,64,03,41,4E,66,66,81
:04:39.045, KL30, (Hex),08,62,64,03,41,4C,CC,CD,80

*** Battery Value only

16
16
16

:04:39.245, KL30, 12.8000001907349, 12.8
:04:39.457, KL30, 12.8999996185303, 12.9
:04:39.687, KL30, 13.1000003814697, 13.1

*** Battery Value in Full Description

16
16
16

:04:39.905, KL30, IEEE Batt.Volt = 13 V, Norm Batt.Volt = 13 V
:04:40.097, KL30, IEEE Batt.Volt = 13 V, Norm Batt.Volt = 13 V
:04:40.305, KL30, IEEE Batt.Volt = 13.1000003814697 V, Norm Batt.Volt = 13.1 V

*** Just the received Diagnostic Data String

16:
16:
16:

04:40.648, KL30, (Hex),08,62,64,03,41,51,99,9A,83
04:40.851, KL30, (Hex),08,62,64,03,41,51,99,9A,83
04:41.069, KL30, (Hex),08,62,64,03,41,51,99,9A,83

*** Battery Value only

16:
l6:
l6:

04:41.278, KL30, 13.1000003814697, 13.1
04:41.481, KL30, 13.1000003814697, 13.1
04:41.684, KL30, 13.1999998092651, 13.2

*** Battery Value in Full Description

l6:
l6:
l6:

04:41.902, KL30, IEEE Batt.Volt = 13.1000003814697 V, Norm Batt.Volt = 13.1 V
04:42.105, KL30, IEEE Batt.Volt = 13 V, Norm Batt.Volt = 13 V
04:42.298, KL30, IEEE Batt.Volt = 12.8999996185303 VvV, Norm Batt.Volt = 12.9 V
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14 Appendix B: Scripting file sample to Log data with Tab Space as Separator

This demonstration illustrates the Data Log of 100 Data into a file, the data is separated by Tab Space; thus, they are easily
be copied to an Excel Worksheets, so that Graph can be plotted for visual analysis.

14.1. Original Scripting Text in File

*** WT I1S014229 UDS CAN Tool: Scripting *** // This is the Scripting File Identification
Erase: DialogPanel

//ErrorOnReplyData: ReplyDataNotMatch=Stop
ErrorOnReplyData: ReplyDataNotMatch= Cont

//ErrorOnReplyData: NegativeResponse = Stop
//ErrorOnReplyData: NegativeResponse = Cont

Show: CmdStrAll = On
#: Variable = v_Data0
#: Variable = v Datal, v Data2, v_Data3 // Declaring 3 variables
Show: CmdStrAll = Off
#: Variable = v_Data4

Variable = v_LoopCounter

Constant = c_RdDataByID equ 0x22
Constant = c_DID RdVbattIEEE equ 0x6403
Constant = c_50ms equ 50

Constant = c_10ms equ 10

H= = H S

Show: CmdStrAll = Off

File: OpenLogFile = Use Tab for Data Separator // or Comma
//File: DataSeparator = Comma // or Tab

File: Print = // Blank Line

File: Print =

AR KK A A AR AR A A A A A A A R A A A A A AR A A A A A A A R A A A A A A A R AR A A A A AR AR A A A AR AR A A kAR AR Ak kA A A Ak kA kA A A Ak hh kA Ak Ak hk ok hhk Ak hkhkhk kA kA xk ok kkk
File: Print = *** Note: Tab Space is used for Data separator for this exercise; Data can directly copy to Excel
File: Print =

AR AR A A A A AR A A A A A A A R A A A A A A A A A A A A A R A A A A A A A R AR A A A A AR AR A A A AR AR A A I AR AR A A kA A A A A kA kA A A Ak hh kA Ak Ak hhhk Ak hkhkhkhkhk kA xk ok kkk

File: Print = // Blank Line
#: v_LoopCounter = 100

Tx (DiagnosticMode): Default
File: Print = *** Battery Value only

Repeat
Tx (KL30): c_RdDataByID, (ul6)c_DID_RdVbattIEEE
//Show: RxData = KL30 = VS$> IEEE Batt.Volt (F;1;4;IEEE754;V) :Norm Batt.Volt (F;5;1;D*0.1;V)
File: RxData = KL30 = V$> IEEE Batt.Volt(F;1;4;IEEE754;V) :Norm Batt.Volt(F;5;1;D*0.1;V)
Pause: c_50ms

#: v_LoopCounter = v_LoopCounter -1

loop: v_LoopCounter != 0
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14.2. Output of Log File

// WT UDS CAN Scripting - Log File for Diagnostic Receive Data

// Init File selected: UDS Demo ECU CAN-Generic 29bit ID w_IEEE754 200717.ini
// Scripting File Directory: M:\A3\Diagnostic\MlA Brazil\EEPROM update
// Scripting File name: AppendixB-RdDataByID - Battery Voltage then export to Excel .scp

//

// Tester Transmit ID - Std: Ox1ABCD71B
// - Alt: Ox1ABCD7DF
// Tester Receive ID: Ox1ABCD79B

//

// Date: 2020-Jul-29
// Time: 16:23:11.650

[k ok Kk ok Kk ok Kk ok ok Kk ok KKk ok K Kk ok Kk ok ok ok Kk ok ok ok Kk ok ok ok Kk ok ok ok Kk ok ok ok Kk ok ok ok Kk ok ok ok Kk

ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok ok K ok K ok ok ok kK ok K ok ok ok kK ok K ok k ok ok K ok K ok k ok kK ok K ok K ok ok ok kK ok K ok ok ok k Kk K ok kK k Kk Kk ok

*** Note: Tab Space is used for Data separator for this exercise; Data can directly copy to Excel
Kk kK ko Kk KK ko Kk KK ko Kk KK ko Kk KK kKR KK kKR R ko Kk R ko Kk o K kK ko Kk kK kR kK ko Kk kK ko Kk kK ko K

*** Battery Value only 16:23:26.485 KL30 13 13
16:23:16.216 KL30 13.1000003814697 13.1 16:23:26.688 KL30 13 13
16:23:16.434 KL30 13.1000003814697 13.1 16:23:26.891 KL30 13 13
16:23:16.637 KL30 13.1000003814697 13.1 16:23:27.078 KL30 13 13
16:23:16.845 KL30 13 13 16:23:27.296 KL30 13 13
16:23:17.063 KL30 13 13 16:23:27.515 KL30 12.8999996185303 12.9
16:23:17.266 KL30 13 13 16:23:27.718 KL30 13 13
16:23:17.484 KL30 13.1000003814697 13.1 16:23:27.921 KL30 13.1000003814697 13.1
16:23:17.688 KL30 13.1000003814697 13.1 16:23:28.262 KL30 13.1000003814697 13.1
16:23:17.885 KL30 13.1000003814697 13.1 16:23:28.465 KL30 13.1000003814697 13.1
16:23:18.087 KL30 13 13 16:23:28.668 KL30 13.1000003814697 13.1
16:23:18.290 KL30 13.1000003814697 13.1 16:23:28.887 KL30 13.1000003814697 13.1
16:23:18.493 KL30 13 13 16:23:29.101 KL30 13.1000003814697 13.1
16:23:18.712 KL30 13 13 16:23:29.320 KL30 13 13
16:23:18.915 KL30 13 13 16:23:29.539 KL30 13 13
16:23:19.131 KL30 13.1000003814697 13.1 16:23:29.742 KL30 13.1000003814697 13.1
16:23:19.334 KL30 13 13 16:23:29.945 KL30 13.1000003814697 13.1
16:23:19.537 KL30 13 13 16:23:30.146 KL30 13 13
16:23:19.740 KL30 13 13 16:23:30.365 KL30 13 13
16:23:19.941 KL30 13.1000003814697 13.1 16:23:30.568 KL30 13.1000003814697 13.1
16:23:20.144 KL30 13.1000003814697 13.1 16:23:30.771 KL30 13.1999998092651 13.2
16:23:20.362 KL30 13 13 16:23:30.989 KL30 13.1000003814697 13.1
16:23:20.565 KL30 13 13 16:23:31.191 KL30 13.1000003814697 13.1
16:23:20.784 KL30 12.8999996185303 12.9 16:23:31.394 KL30 13.1000003814697 13.1
16:23:20.983 KL30 13 13 16:23:31.598 KL30 13 13
16:23:21.186 KL30 12.8000001907349 12.8 16:23:31.816 KL30 13.1000003814697 13.1
16:23:21.389 KL30 12.8000001907349 12.8 16:23:32.015 KL30 13.1000003814697 13.1
16:23:21.592 KL30 12.6999998092651 12.7 16:23:32.215 KL30 13 13
16:23:21.811 KL30 12.8000001907349 12.8 16:23:32.418 KL30 13 13
16:23:22.012 KL30 12.8999996185303 12.9 16:23:32.621 KL30 13.1000003814697 13.1
16:23:22.215 KL30 12.8000001907349 12.8 16:23:32.840 KL30 13.1000003814697 13.1
16:23:22.418 KL30 12.8999996185303 12.9 16:23:33.045 KL30 13 13
16:23:22.637 KL30 12.8000001907349 12.8 16:23:33.260 KL30 13.3000001907349 13.3
16:23:22.840 KL30 13 13 16:23:33.463 KL30 12.8999996185303 12.9
16:23:23.041 KL30 13 13 16:23:33.666 KL30 13 13
16:23:23.244 KL30 12.8000001907349 12.8 16:23:33.869 KL30 12.8999996185303 12.9
16:23:23.463 KL30 12.8999996185303 12.9 16:23:34.087 KL30 12.8999996185303 12.9
16:23:23.666 KL30 12.8999996185303 12.9 16:23:34.288 KL30 12.8999996185303 12.9
16:23:23.885 KL30 13.1000003814697 13.1 16:23:34.491 KL30 12.8000001907349 12.8
16:23:24.081 KL30 13 13 16:23:34.694 KL30 13 13
16:23:24.284 KL30 12.8999996185303 12.9 16:23:34.897 KL30 13.1000003814697 13.1
16:23:24.487 KL30 13.1000003814697 13.1 16:23:35.118 KL30 12.8999996185303 12.9
16:23:24.690 KL30 13.1000003814697 13.1 16:23:35.316 KL30 13.1000003814697 13.1
16:23:24.893 KL30 13 13 16:23:35.519 KL30 13 13
16:23:25.079 KL30 13.1000003814697 13.1 16:23:35.722 KL30 13.1000003814697 13.1
16:23:25.282 KL30 13 13 16:23:35.941 KL30 13.1000003814697 13.1
16:23:25.485 KL30 12.8999996185303 12.9 16:23:36.143 KL30 13 13
16:23:25.688 KL30 13.1000003814697 13.1 16:23:36.346 KL30 12.8999996185303 12.9
16:23:25.892 KL30 13.1000003814697 13.1 16:23:36.549 KL30 12.8999996185303 12.9
16:23:26.078 KL30 13.1000003814697 13.1 16:23:36.768 KL30 13 13
16:23:26.282 KL30 13 13
14.3. Analysis on 100 Data by Excel Graph
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